Junio C Hamano <gitster@xxxxxxxxx> writes: > Jeff King <peff@xxxxxxxx> writes: > ... >> That's a lot more tedious "if (!in_signal)" checks, but: >> >> - we don't have to duplicate any of the actual application logic >> >> - we'd now cover the extra cases for waitpid failing or returning the >> wrong pid (previously if waitpid() failed we'd still look at status, >> which could contain complete garbage!) > ... > Yeah, the repeated "if (!in_signal)" look a bit ugly, but fixing > that "we only deal with ifexited in in_signal case" to do the right > thing would make the code even more annoying and harder to maintain. Eh, what I meant was that it would be annoying and harder to maintain, if done inside the single "if (in_signal) { ... }" near the beginning. (IOW, I am completely in agreement with your reasoning above).