Øystein Walle <oystwa@xxxxxxxxx> writes: > Make the counting of stash entries contained in one simple function as > it will be used in the next commit. > > Signed-off-by: Øystein Walle <oystwa@xxxxxxxxx> > --- > wt-status.c | 10 ++++++++-- > 1 file changed, 8 insertions(+), 2 deletions(-) > > diff --git a/wt-status.c b/wt-status.c > index e4f29b2b4c..97230477b2 100644 > --- a/wt-status.c > +++ b/wt-status.c > @@ -948,11 +948,17 @@ static int stash_count_refs(struct object_id *ooid, struct object_id *noid, > return 0; > } > > +static int count_stash_entries() Probably "static int count_stash_entries(void)" was what was meant here. > +{ > + int n = 0; Have a blank line between the block of decls at the beginning of the function and the first statement. > + for_each_reflog_ent("refs/stash", stash_count_refs, &n); > + return n; > +} I briefly wondered if this want to be size_t or some other unsigned integral type, but this is merely refactoring the existing code, so it is not just OK but is correct to use the same "int" as before. > static void wt_longstatus_print_stash_summary(struct wt_status *s) > { > - int stash_count = 0; > + int stash_count = count_stash_entries(); > > - for_each_reflog_ent("refs/stash", stash_count_refs, &stash_count); > if (stash_count > 0) > status_printf_ln(s, GIT_COLOR_NORMAL, > Q_("Your stash currently has %d entry", OK.