On Sat, Sep 18, 2021 at 6:05 PM Jeff King <peff@xxxxxxxx> wrote: > Swapping out the "printf >expect" for a here-doc might make it a bit > more readable. I used printf because of the tab handling, but: > > tab=$(printf "\t") > cat >expect <<-EOF > ref: ${dst}${tab}HEAD > ${oid}${tab}HEAD > EOF > > isn't too bad. Or just use q_to_tab(): q_to_tab >expect <<-EOF ref: ${dst}QHEAD ${oid}QHEAD EOF However, the typical use-case for q_to_tab() is when we need a leading or trailing TAB character. When TAB is embedded within the line, we often just use a literal TAB character; indeed, many tests in the suite do exactly that, so that would be an even simpler option.