"Maksym Sobolyev via GitGitGadget" <gitgitgadget@xxxxxxxxx> writes: > From: Maksym Sobolyev <sobomax@xxxxxxxxxxxxx> > > This allows ident to be something like $FreeBSD$ so it provides matching > functionality for repos migrated from CVS / SVN. > > This works by allowing ident to have a parameter, i.e.: > > * ident=MyCustomId > > In .gitattributes. > > Signed-off-by: Maksym Sobolyev <sobomax@xxxxxxxxxxxxx> Just like cvs uses its configuration mechanism for LocalKeyword, this belongs to the .git/config file. The attribute mechanism is inherently for stuff that you would want to specify per-path, so the "do we do keyword expansion for this file (yes/no)?" is a good match to be an attribute, and that question is what the original 'ident' attribute asks. I do not think "what keyword do we want to expand as if it were $Id$?" is a question we want to be giving different answers per path, and it does not smell like a good match to be an attribute. By allowing a potentially separate values for *.txt ident=FreeBSD *.cc ident=OpenBSD this gives long rope to create a mess to the users. In addition, a project can easily attack and break its users by having .gitattributes with overly long ident defined, as it would cause the attribute code to trigger the die() call added by this patch. In short, I do not think the approach taken by this patch to use per-path attribute is a good idea at all. I suspect that this patch mimics crlf_action when naming the new "ident_action" thing, but that is a poor choice. crlf_action does specify what different actions to be taken, but the setting does not change the way 'ident' filter behaves in any fundamental way. It just changes the constant string used to locate and replace from $Id$ to something else. ident_keyword (as this is "keyword expansion" behaviour) may be a better name. There is no inherent reason why the custom ident string must be shorter than 255, even though it might not be a bad idea to have a reasonable floor for the length.