> > @@ -120,7 +120,16 @@ struct grep_opt { > > struct grep_pat *header_list; > > struct grep_pat **header_tail; > > struct grep_expr *pattern_expression; > > + > > + /* > > + * NEEDSWORK: See if we can remove this field, because the repository > > + * should probably be per-source, not per-repo. > > Hmm, I think the "not per-repo" part is a bit confusing, as it refers > to "the repository" ("the repository should not be per-repo"?) Could > we remove that part? > > Maybe we could also be a bit more specific regarding the suggested > conversion: "See if we can remove this field, because the repository > should probably be per-source. That is, grep.c functions using > `grep_opt.repo` should probably start using `grep_source.repo` > instead." (But that's nitpicking from my part, feel free to ignore > it.) Thanks - your suggestion is much clearer, so I'll use it.