"Joel Klinghed" <the_jk@xxxxxxxxxxx> writes: >> Writing this as >> >> if (edit_flag < 0) >> >> makes it far easier to immediately see that we are talking about a >> nagetive edit_flag. >> > > Agree, I'll change it. > I was unsure of the style and copied from the earlier condition: > if (0 <= edit_flag) > use_editor = edit_flag; There are two valid schools of thought when it comes to comparison. Some folks consider that a comparison between a variable and a constant is a statement about the variable, hence the expression should be if (VARIRABLE comparison-operator CONSTANT) They will write things like: if (edit_flag >= 0) if (edit_flag < 0) Other folks consider that textual order of the comparison should match the actual order of the things being compared, as if they are arranged on a number line, hence the expression should be if (SMALLER < LARGER) no matter which one is variable and which one is constant. They will write: if (0 <= edit_flag) if (edit_flag < 0) The case in question, asserting that edit_flag is negative, is what both camps agree how to write.