Function `traverse_trees_and_blobs` not only works on trees and blobs, but also on tags, the function name is somewhat misleading. This commit rename it to `traverse_trees_and_blobs_and_tags`. Signed-off-by: Teng Long <dyroneteng@xxxxxxxxx> --- list-objects.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/list-objects.c b/list-objects.c index 7f404677d5..37a37fc502 100644 --- a/list-objects.c +++ b/list-objects.c @@ -334,7 +334,7 @@ static void add_pending_tree(struct rev_info *revs, struct tree *tree) add_pending_object(revs, &tree->object, ""); } -static void traverse_trees_and_blobs(struct traversal_context *ctx, +static void traverse_trees_and_blobs_and_tags(struct traversal_context *ctx, struct strbuf *base) { int i; @@ -407,9 +407,9 @@ static void do_traverse(struct traversal_context *ctx) * needs a reallocation for each commit. Can we pass the * tree directory without allocation churn? */ - traverse_trees_and_blobs(ctx, &csp); + traverse_trees_and_blobs_and_tags(ctx, &csp); } - traverse_trees_and_blobs(ctx, &csp); + traverse_trees_and_blobs_and_tags(ctx, &csp); strbuf_release(&csp); } -- 2.32.0.dirty