Re: [PATCH 4/4] promisor-remote: teach lazy-fetch in any repo

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



> > +static void object_info(const char *gitdir, const char *oid_hex)
> > +{
> > +	struct repository r;
> > +	struct object_id oid;
> > +	unsigned long size;
> > +	struct object_info oi = {.sizep = &size};
> > +	const char *p;
> > +
> > +	if (repo_init(&r, gitdir, NULL))
> > +		die("could not init repo");
> > +	if (parse_oid_hex(oid_hex, &oid, &p))
> > +		die("could not parse oid");
> > +	if (oid_object_info_extended(&r, &oid, &oi, 0))
> > +		die("could not obtain object info");
> > +	printf("%d\n", (int) size);
> > +}
> 
> Hmm. Is there a reason that the same couldn't be implemented by calling "git
> cat-file -s" from the partial clone?

I don't think "git cat-file" (when run in the superproject) by itself
can access an object from a submodule. "git -C name_of_submodule
cat-file $HASH" would access that object, but I specifically want to
test oid_object_info_extended() on a repo that is not the_repository
(which would not work with -C, because the_repository would then be the
submodule).

> > +test_expect_success 'lazy-fetch when accessing object not in the_repository' '
> > +	rm -rf full partial.git &&
> > +	test_create_repo full &&
> > +	printf 12345 >full/file.txt &&
> > +	git -C full add file.txt &&
> > +	git -C full commit -m "first commit" &&
> 
> This is a stylistic nit, but I think using test_commit is better here
> for a non-superficial reason. My guess is that you wanted to avoid
> specifying a message and file (which are required positional arguments
> to test_commit before you can specify the contents). But I think there
> are two good reasons to use test_commit here:
> 
>   - It saves three lines of test script here.
>   - You don't have to make the expected size a magic number (i.e.,
>     because you knew ahead of time that the contents was "12345").
> 
> I probably would have expected this test to end with:
> 
>   git -C full cat-file -s $FILE_HASH >expect &&
>   git -C partial.git cat-file -s $FILE_HASH >actual &&
>   test_cmp expect actual
> 
> which reads more clearly to me (although I think the much more important
> test is that $FILE_HASH doesn't show up in the output of the rev-list
> --missing=print that is run in the partial clone).

That makes sense.

> > +	test_config -C full uploadpack.allowfilter 1 &&
> > +	test_config -C full uploadpack.allowanysha1inwant 1 &&
> > +	git clone --filter=blob:none --bare "file://$(pwd)/full" partial.git &&
> > +	FILE_HASH=$(git hash-object --stdin <full/file.txt) &&
> 
> This works for me, although I wouldn't have been sad to see the
> sub-shell contain "git -C full rev-parse HEAD:file.txt" instead.

I'll do this too.

> > +	# Sanity check that the file is missing
> > +	git -C partial.git rev-list --objects --missing=print HEAD >out &&
> > +	grep "[?]$FILE_HASH" out &&
> > +
> > +	OUT=$(test-tool partial-clone object-info partial.git "$FILE_HASH") &&
> 
> Coming back to my point about the utility of the partial-clone helper,
> could this be replaced by saying just OUT="$(git -C partial.git cat-file
> -s "$FILE_HASH")" instead?
> 
> Thanks,
> Taylor

Same answer as above - I specifically want to test accessing (and
thereby lazy-fetching) an object when the object is not in
the_repository. I'll add some documentation to explain what it does and
that it's equivalent to using "git -C repo cat-file -s", except that
this specifically tests another code path.



[Index of Archives]     [Linux Kernel Development]     [Gcc Help]     [IETF Annouce]     [DCCP]     [Netdev]     [Networking]     [Security]     [V4L]     [Bugtraq]     [Yosemite]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Linux SCSI]     [Fedora Users]

  Powered by Linux