From: ZheNing Hu <adlternative@xxxxxxxxx> Because the two "if (opt->all_objects)" block are redundant, merge them into one, to provide better readability. Helped-by: Jeff King <peff@xxxxxxxx> Signed-off-by: ZheNing Hu <adlternative@xxxxxxxxx> --- builtin/cat-file.c | 5 +---- 1 file changed, 1 insertion(+), 4 deletions(-) diff --git a/builtin/cat-file.c b/builtin/cat-file.c index 02461bb5ea6f..243fe6844bc6 100644 --- a/builtin/cat-file.c +++ b/builtin/cat-file.c @@ -520,14 +520,11 @@ static int batch_objects(struct batch_options *opt) data.info.typep = &data.type; if (opt->all_objects) { + struct object_cb_data cb; struct object_info empty = OBJECT_INFO_INIT; if (!memcmp(&data.info, &empty, sizeof(empty))) data.skip_object_info = 1; - } - - if (opt->all_objects) { - struct object_cb_data cb; if (has_promisor_remote()) warning("This repository uses promisor remotes. Some objects may not be loaded."); -- gitgitgadget