On Fri, May 28, 2021 at 1:10 PM Felipe Contreras <felipe.contreras@xxxxxxxxx> wrote: > > Git is a *distributed* version control system, centralized workflows are > the uncommon case, where we do need to do extra checks. The commit message seemed slightly funny to me, though I'm not sure why. However... > Signed-off-by: Felipe Contreras <felipe.contreras@xxxxxxxxx> > --- > builtin/push.c | 16 ++++++++-------- > 1 file changed, 8 insertions(+), 8 deletions(-) > > diff --git a/builtin/push.c b/builtin/push.c > index 8ecfbe8d63..1856f62861 100644 > --- a/builtin/push.c > +++ b/builtin/push.c > @@ -186,7 +186,7 @@ static const char message_detached_head_die[] = > " git push %s HEAD:<name-of-remote-branch>\n"); > > static void setup_push_upstream(struct remote *remote, struct branch *branch, > - int triangular) > + int centralized) > { > if (!branch) > die(_(message_detached_head_die), remote->name); > @@ -201,7 +201,7 @@ static void setup_push_upstream(struct remote *remote, struct branch *branch, > if (branch->merge_nr != 1) > die(_("The current branch %s has multiple upstream branches, " > "refusing to push."), branch->name); > - if (triangular) > + if (!centralized) > die(_("You are pushing to remote '%s', which is not the upstream of\n" > "your current branch '%s', without telling me what to push\n" > "to update which remote branch."), > @@ -210,12 +210,12 @@ static void setup_push_upstream(struct remote *remote, struct branch *branch, > refspec_appendf(&rs, "%s:%s", branch->refname, branch->merge[0]->src); > } > > -static void setup_push_simple(struct remote *remote, struct branch *branch, int triangular) > +static void setup_push_simple(struct remote *remote, struct branch *branch, int centralized) > { > if (!branch) > die(_(message_detached_head_die), remote->name); > > - if (!triangular) { > + if (centralized) { > if (!branch->merge_nr || !branch->merge || !branch->remote_name) > die(_("The current branch %s has no upstream branch.\n" > "To push the current branch and set the remote as upstream, use\n" > @@ -238,7 +238,7 @@ static void setup_push_simple(struct remote *remote, struct branch *branch, int > static void setup_default_push_refspecs(struct remote *remote) > { > struct branch *branch = branch_get(NULL); > - int triangular = remote != remote_get(NULL); > + int centralized = remote == remote_get(NULL); > > switch (push_default) { > default: > @@ -248,15 +248,15 @@ static void setup_default_push_refspecs(struct remote *remote) > > case PUSH_DEFAULT_UNSPECIFIED: > case PUSH_DEFAULT_SIMPLE: > - setup_push_simple(remote, branch, triangular); > + setup_push_simple(remote, branch, centralized); > break; > > case PUSH_DEFAULT_UPSTREAM: > - setup_push_upstream(remote, branch, triangular); > + setup_push_upstream(remote, branch, centralized); > break; > > case PUSH_DEFAULT_CURRENT: > - setup_push_simple(remote, branch, 1); > + setup_push_simple(remote, branch, 0); > break; > > case PUSH_DEFAULT_NOTHING: > -- > 2.32.0.rc0 ...I think the code is slightly easier to read and reason about since it removes the double negative. In particular, when someone reading the code sees !triangular, and doesn't know or remember the meaning, they have to translate that to !(remote != remote_get(NULL)). centralized and !centralized do not have that same problem. So, I like the newer version.