Firmin Martin <firminmartin24@xxxxxxxxx> writes: > +/* > + * This function should not be used for regular prompts (i.e., asking user for > + * confirmation or picking an option from an interactive menu) as it only > + * accepts input from /dev/tty, thus making it impossible to test with the > + * current test suite. Please instead use git_read_line_interactively for that > + * purpose. See 97387c8bdd (am: read interactive input from stdin, 2019-05-20) > + * for historical context. > + * > + */ I have a strong objection against the above phrasing. If we are asking user for interactive input, this SHOULD be used, especially if we might be reading the data to work on from the standard input and we may need to ask the user to interactively instruct us what to do to that data. The only plausible reason that we may want to avoid it and instead prefer the (misnamed) read_line_interactively() to read whatever from the standard input (which may not be "interactive" at all, which is why I said "misnamed") is because our test framework does not use setsid (and setsid(1) may not be universally available) with pty to emulate tty input, isn't it? > char *git_prompt(const char *prompt, int flags); > > int git_read_line_interactively(struct strbuf *line);