Atharva Raykar <raykar.ath@xxxxxxxxx> writes: >>> + "(\\.|[^][)(\\}\\{ ])+"), >> >> One or more "dot or anything other than SP or parentheses"? But >> a dot "." is neither a space or any {bra-ce} letter, so would the >> above be equivalent to >> >> "[^][()\\{\\} \t]+" >> >> I wonder... > > A backslash is allowed in scheme identifiers, and I erroneously thought that > the first part handles the case for identifiers such as `component\new` or > `\"id-with-quotes\"`. (I tested it with a regex engine that behaves differently > than the one git is using, my bad.) Ah, perhaps you didn't have enough backslashes. A half of the doubled one before the dot is eaten by the C compiler, so the regexp engine is seeing only a single backslash before the dot, which means "literally a single dot". If you meant "literally a single backslash, followed by any single char", you probably would write 4 backslashes and a dot---half of the backslashes would be eaten by the compiler, so you'd be passing two backslashes and a dot, which is probably what you meant. Having said that, two further points. - the "anything but whitespaces and various forms of parentheses" set would include backslash, so 'component\new' would be taken as a single word with "[^][()\\{\\} \t]+", wouldn't it? - how common is the use of backslashes in identifiers? I am trying to see if the additional complexity needed to support them is worth the benefit. > But somehow, the regexp you suggested, ie: > > "[^][()\\{\\} \t]+" > > does not handle the case of make\foo -> make\bar (it will only diff on foo). > I am not too sure why it treats backslashes as delimiters. Perhaps because you have included two backslashes inside [] to say "backslash is not a word character" in the original, and I blindly copied that? IOW, do you need to quote {} inside []? > Yes, this is exactly what I was trying to express. All words should be > delimited by either whitespace or a parenthesis, and all other special > characters should be accepted as part of the word. That sentence after "All words should be..." would be a good comment to replace what you wrote in the original, then ;-).