On Tue, Jan 12, 2021 at 04:32:39AM -0500, Jeff King wrote: > Good catch. We might want to drop the initialization of "lo": > > > int lo = 0; > > - int hi = p->num_objects + 1; > > down to here: > > > + hi = p->num_objects + 1; > to maintain symmetry (though it's quite a minor point). :-). I agree it's a minor point, but I think that the symmetry is nice, so it's worth doing. > I notice these are signed ints, but we've taken care to use uint32_t > elsewhere for positions. Shouldn't these be uint32_t, also (or at least > unsigned)? I'll let both of these be an raw unsigned, since the midpoint is already labeled as an unsigned. > -Peff Thanks, Taylor