We have some source files with filenames such as sha1-lookup.c and sha1-name.c containing a few variable names, comments and the like referencing "sha1". But they are able to handle SHA-256 as well. Here's my attempt at removing "sha1" from the contents and names of these files. Martin Ågren (4): object-name.c: rename from sha1-name.c object-file.c: rename from sha1-file.c sha1-lookup: rename `sha1_pos()` as `hash_pos()` hash-lookup: rename from sha1-lookup t/oid-info/README | 2 +- sha1-lookup.h => hash-lookup.h | 14 +++++++------- bisect.c | 2 +- builtin/index-pack.c | 2 +- builtin/name-rev.c | 4 ++-- commit-graph.c | 8 ++++---- commit.c | 4 ++-- sha1-lookup.c => hash-lookup.c | 22 +++++++++++----------- list-objects-filter.c | 2 +- midx.c | 2 +- sha1-file.c => object-file.c | 4 ++-- sha1-name.c => object-name.c | 14 +++++++------- oid-array.c | 4 ++-- pack-bitmap-write.c | 4 ++-- packfile.c | 2 +- patch-ids.c | 2 +- rerere.c | 4 ++-- Makefile | 6 +++--- 18 files changed, 51 insertions(+), 51 deletions(-) rename sha1-lookup.h => hash-lookup.h (72%) rename sha1-lookup.c => hash-lookup.c (84%) rename sha1-file.c => object-file.c (99%) rename sha1-name.c => object-name.c (99%) -- 2.30.0