Junio C Hamano wrote: > Derrick Stolee <stolee@xxxxxxxxx> writes: > > > On 12/15/2020 12:53 PM, Elijah Newren via GitGitGadget wrote: > >> From: Elijah Newren <newren@xxxxxxxxx> > >> > >> In a subsequent commit, we will implement the traditional recursiveness > >> that gave merge-recursive its name, namely merging non-unique > >> merge-bases to come up with a single virtual merge base. Copy a few > >> helper functions from merge-recursive.c that we will use in the > >> implementation. > > > > I'm sure these are copies, but... > > > >> +static struct commit_list *reverse_commit_list(struct commit_list *list) > >> +{ > >> + struct commit_list *next = NULL, *current, *backup; > >> + for (current = list; current; current = backup) { > >> + backup = current->next; > >> + current->next = next; > >> + next = current; > >> + } > > > > The naming of 'next' seems backwards to me, since it is really > > the "previous" node. Using something like 'previous' makes it > > clear that you are reversing when you say > > > > current->next = previous; > > Hmph. I took "next" commit_list as "list is the original one, and > next is the reversed list, the next generation of what we received". > > Calling it "previous" feels even more backwards when you view among > three "struct commit_list *" pointers, one (the one that holds the > eventual return value) is primarily used to denote the resulting > list itself, and the other two are used to point individual elements > on the original list. Both feel awkward to me because to me previous/next are actually current in my mind, and we should return current, not previous/next. Plus there's no need for current, we can use list, as your example. This is what I came up with: struct commit_list *current = NULL; while (list) { struct commit_list *tmp = list->next; list->next = current; current = list; list = tmp; } return current; For completeness I checked how Linux does it, and surprisingly llist_reverse_order() is very close to what I came up with: struct commit_list *new_list = NULL; while (list) { struct commit_list *tmp = list; list = list->next; tmp->next = new_list; new_list = tmp; } return new_list; (obviously translated) Maybe it's just me, but I find my version easier to read. Cheers. -- Felipe Contreras