Hi Junio, On Mon, 23 Nov 2020, Junio C Hamano wrote: > "Johannes Schindelin via GitGitGadget" <gitgitgadget@xxxxxxxxx> > writes: > > > +static const char default_branch_name_advice[] = N_( > > +"Using '%s' as the name for the initial branch. This default branch name\n" > > +"is subject to change. To configure the initial branch name to use in all\n" > > +"of your new repositories, run:\n" > > I think this is good, assuming that "subject to change" covers the > case where we end up doing nothing after all. I'd feel safer if we > said "s/is subject to change/may change in the future/", but this is > not a strong preference. I'd rather keep the current form, as it sounds a bit more firm to me. > > +"\n" > > +"\tgit config --global init.defaultBranch <name>\n" > > +"\n" > > +"Common names are 'main', 'trunk' and 'development'. If you merely wish\n" > > +"to suppress this warning, you can also use the current default branch\n" > > +"name. The current branch can be renamed via this command:\n" > > I think this is worse than the previous one. Those who merely wish > to suppress the message without wanting to commit to a particular > name (i.e. they just want to take whatever the default we give them) > would be mislead and be frozen in time forever. We do not give > "I'll just accept the default of the day" choice, and that is OK, > but we want to be clear about it, which is why I've kept raising this > as an issue. > > To configure the initial branch name to use in all of your new > repositories and squelch this message, run: > > may be better---it makes it clear that the offered two choices are > (1) do nothing and see this message every time, or (2) commit to a > name and not see this message again. Well, I think I finally understand what you are saying: there is a legitimate need for a way to go with Git's preference but still suppress that message. I introduced `advice.defaultBranchName` to that end, and now display prominently, at the top of the message, how to use that flag to avoid seeing this advice ever again. Ciao, Dscho