On Wed, Nov 11, 2020 at 12:13 PM Elijah Newren <newren@xxxxxxxxx> wrote: > On Wed, Nov 11, 2020 at 6:51 AM Derrick Stolee <stolee@xxxxxxxxx> wrote: > > If the *_null values were in an array, instead, then all of these > > lines could be grouped as a macro: > > > > unsigned null_oid[3] = { > > !(mask & 1), > > !(mask & 2), > > !(mask & 4) > > }; > > Hmm, I like it. I think I'll rename trivial_merge() to > non_null_match() (trivial merge suggests it can immediately be > resolved which is not necessarily true if rename detection is on), but > otherwise I'll use this. Are we allowing non-constant array initializers in the codebase these days? I don't see anything in CodingGuidelines suggesting the use of them.