This patch series contains a bunch fo trailer related changes. Sparked from this thread: https://public-inbox.org/git/87blk0rjob.fsf@xxxxxxx/T/#r3dc3e4fa67b6fba95e4b2ea2c1cf1672af55a9ee Most commits are refactors preparing for the others, the actual user visible changes are: * Allow using aliases in pretty formatting '%(trailer:key=foo)` * Fixes related to matching prefix rather than full trailer * Tighten up "canonicalization" of trailers * Add --(no-)canonicalize Anders Waldenborg (21): trailer: change token_{from,matches}_item into taking conf_info trailer: don't use 'struct arg_item' for storing config doc: mention canonicalization in git i-t manual pretty: allow using aliases in %(trailer:key=xyz) trailer: rename 'free_all' to 'free_all_trailer_items' t4205: add test for trailer in log with nonstandard separator trailer: simplify 'arg_item' lifetime trailer: keep track of conf in trailer_item trailer: refactor print_tok_val into taking item trailer: move trailer token canonicalization print time trailer: remember separator used in input trailer: handle configured nondefault separators explicitly trailer: add option to make canonicalization optional trailer: move skipping of blank lines to own loop when finding trailer trailer: factor out classify_trailer_line t7513: add failing test for configured trailing line classification trailer: don't treat line with prefix of known trailer as known trailer: factor out config lookup to separate function trailer: move config lookup out of parse_trailer trailer: add failing tests for matching trailers against input trailer: only do prefix matching for configured trailers on commandline Documentation/git-interpret-trailers.txt | 10 +- Documentation/pretty-formats.txt | 4 +- builtin/interpret-trailers.c | 3 + pretty.c | 5 +- t/t4205-log-pretty-formats.sh | 18 ++ t/t7513-interpret-trailers.sh | 120 ++++++++ trailer.c | 374 ++++++++++++++--------- trailer.h | 3 +- 8 files changed, 386 insertions(+), 151 deletions(-) -- 2.25.1