(+cc: Dscho for NTFS savvy) Jeff King wrote: > We have tests that cover various filesystem-specific spellings of > ".gitmodules", because we need to reliably identify that path for some > security checks. These are from dc2d9ba318 (is_{hfs,ntfs}_dotgitmodules: > add tests, 2018-05-12), with the actual code coming from e7cb0b4455 > (is_ntfs_dotgit: match other .git files, 2018-05-11) and 0fc333ba20 > (is_hfs_dotgit: match other .git files, 2018-05-02). > > Those latter two commits also added similar matching functions for > .gitattributes and .gitignore. These ended up not being used in the > final series, and are currently dead code. But in preparation for them > being used, let's make sure they actually work by throwing a few basic > checks at them. > > I didn't bother with the whole battery of tests that we cover for > .gitmodules. These functions are all based on the same generic matcher, > so it's sufficient to test most of the corner cases just once. Yeah, that's reasonable. > Note that the ntfs magic prefix names in the tests come from the > algorithm described in e7cb0b4455 (and are different for each file). Doesn't block this patch, but I'm curious: how hard would it be to make a test with an NTFS prerequisite that makes sure we got the magic prefix right? > Signed-off-by: Jeff King <peff@xxxxxxxx> > --- > t/helper/test-path-utils.c | 41 ++++++++++++++++++++++++++------------ > t/t0060-path-utils.sh | 20 +++++++++++++++++++ > 2 files changed, 48 insertions(+), 13 deletions(-) > > diff --git a/t/helper/test-path-utils.c b/t/helper/test-path-utils.c > index 313a153209..9e253f8058 100644 > --- a/t/helper/test-path-utils.c > +++ b/t/helper/test-path-utils.c > @@ -172,9 +172,22 @@ static struct test_data dirname_data[] = { > { NULL, NULL } > }; > > -static int is_dotgitmodules(const char *path) > +static int check_dotgitx(const char *x, const char **argv, > + int (*is_hfs)(const char *), > + int (*is_ntfs)(const char *)) > { > - return is_hfs_dotgitmodules(path) || is_ntfs_dotgitmodules(path); > + int res = 0, expect = 1; > + for (; *argv; argv++) { > + if (!strcmp("--not", *argv)) > + expect = !expect; > + else if (expect != (is_hfs(*argv) || is_ntfs(*argv))) > + res = error("'%s' is %s.%s", *argv, > + expect ? "not " : "", x); > + else > + fprintf(stderr, "ok: '%s' is %s.%s\n", > + *argv, expect ? "" : "not ", x); micronit: extra space on the "res" line. This "if" cascade is a little hard to read, even though it does the right thing. Can we make it more explicit? E.g. if (!strcmp("--not", *argv)) { expect = !expect; continue; } actual = is_hfs(*argv) || is_ntfs(*argv); fprintf(stderr, "%s: '%s' is %s%s", expect == actual ? "ok" : "error", *argv, actual ? "" : "not ", x); if (expect != actual) res = -1; I think it's a little easier to read with either (a) the dot included in the 'x' parameter or (b) the entire ".git" missing from the 'x' parameter. [...] > index 56db5c8aba..b2e3cf3f4c 100755 > --- a/t/t0060-path-utils.sh > +++ b/t/t0060-path-utils.sh > @@ -468,6 +468,26 @@ test_expect_success 'match .gitmodules' ' > .gitmodules,:\$DATA > ' > > +test_expect_success 'match .gitattributes' ' > + test-tool path-utils is_dotgitattributes \ > + .gitattributes \ > + .git${u200c}attributes \ > + .Gitattributes \ > + .gitattributeS \ > + GITATT~1 \ > + GI7D29~1 > +' > + > +test_expect_success 'match .gitignore' ' > + test-tool path-utils is_dotgitignore \ > + .gitignore \ > + .git${u200c}ignore \ > + .Gitignore \ > + .gitignorE \ > + GITIGN~1 \ > + GI250A~1 > +' > + > test_expect_success MINGW 'is_valid_path() on Windows' ' > test-tool path-utils is_valid_path \ > win32 \ With whatever subset of the changes above makes sense, Reviewed-by: Jonathan Nieder <jrnieder@xxxxxxxxx> Thanks.