Re: [PATCH v3 0/2] fmt-merge-msg: selectively suppress "into <branch>"

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Thu, Jul 30, 2020 at 11:02:35AM -0700, Junio C Hamano wrote:

> So, this is the third iteration, which separates the reversion that
> involves too many uninteresting test changes, and the implementation
> of the new feature proper.

Thanks, that did make it much easier to read.

> Two things that changed in the implementation since the previous
> iterations are
> 
>  - An assignment-less 'truth', i.e.
> 
> 	[merge] suppressDest
> 
>    is now an error ("missing value for 'merge.suppressDest'"), not
>    "clear the list", which should be spelled as an empty string, i.e.
> 
>         [merge] suppressDest = ""

OK. I don't have a preference either way on the "truth" behavior, but
certainly considering it an error is the conservative thing.

>  - Scanning of dest_patterns to see if "into <branch>" is suppressed
>    for the current_branch is done in a helper function to make the
>    main codeflow easier to read, as suggested by Peff.

Thanks.

This version looks OK to me. The remaining issues that came up in
earlier discussion but I didn't see you weigh in on are:

  - what should happen with a detached HEAD? We'd match HEAD in the
    suppressDest config, which I think is quite reasonable. Not sure if
    it's worth documenting or testing that specifically.

  - should "master" be in the list even if you configure a value? That
    would do the wrong thing if you have a non-integration master, but
    that seems unlikely. And it would do the right thing if somebody
    later puts "main" in merge.suppressDest, but still occasionally
    works with "master" repos (where "right" is defined as "what they
    probably wanted", but it is perhaps a bit magical).

  - what's the plan if we do switch init.defaultBranch to "main"? Would
    we add default_branch() to the list of defaults alongside "master",
    or just add "main", or just leave it and let people configure
    independently? It doesn't need to be decided now, but maybe worth
    thinking about.

-Peff



[Index of Archives]     [Linux Kernel Development]     [Gcc Help]     [IETF Annouce]     [DCCP]     [Netdev]     [Networking]     [Security]     [V4L]     [Bugtraq]     [Yosemite]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Linux SCSI]     [Fedora Users]

  Powered by Linux