Hi, Stolee and Elijah I think I just finished addressing the comments on patch 2/3 [1]. And I'm now looking at the ones in 3/3 (this one). Below are some questions, just to make sure I'm going in the right direction with this one. On Tue, Mar 31, 2020 at 5:02 PM Derrick Stolee <stolee@xxxxxxxxx> wrote: > > On 3/31/2020 3:12 PM, Elijah Newren wrote: > > > > Anyway, maybe it will help if I provide a very rough first draft of > > what changes we could introduce to Documentation/config/core.txt, and > > then ask a bunch of my own questions about it below: > > > > """ > > core.restrictToSparsePaths:: > > Only meaningful in conjuntion with core.sparseCheckoutCone. > > This option extends sparse checkouts (which limit which paths > > are written to the worktree), so that output and operations > > are also limited to the sparsity paths where possible and > > implemented. The purpose of this option is to (1) focus > > output for the user on the portion of the repository that is > > of interest to them, and (2) enable potentially dramatic > > performance improvements, especially in conjunction with > > partial clones. ... > > """ > > > > Several questions here, of course: > > > > * do people like or hate the name? indifferent? have alternate ideas? > > It's probably time to create a 'sparse-checkout' config space. That > would allow > > sparse-checkout.restrictGrep = true > > as an option. Or a more general > > sparse-checkout.restrictCommands = true > > to make it clear that it affects multiple commands. If we are creating the new namespace, 'core.sparseCheckout' should also be renamed to something like 'sparse-checkout.enabled', right? And maybe we could use 'sparsecheckout.*', instead? That seems to be the convention for settings on hyphenated commands (as in sendemail.*, uploadpack.* and gitgui.*). As for compatibility, when running `git sparse-checkout init`, if the config file already has the core.sparseCheckout setting, should we remove it? Or just add the new sparsecheckout.enabled config, which will always be read first? Also, should we emit a warning about the former being deprecated? The good thing about deprecation warnings, IMO, is that users will know the name change faster. But, at least for `git grep <tree>`, where we read core.sparseCheckout and core.sparseCheckoutCone for each submodule and each tree, there would be too much pollution in the output... Finally, about restrictCommands, the idea is to have both sparsecheckout.restrictCommands and `git --restrict-to-sparse-paths`, right? For now, the option/setting would only affect grep, but support would be added gradually to other commands in the future. I noticed git-read-tree already has a --no-sparse-checkout option. Should we remove this option in favor of the global --[no]-restrict-to-sparse-paths? Sorry for too many questions. I just wanted to make sure that I understood the plan before diving into the implementation, to avoid going in the wrong direction. [1]: Here is a sneak peek for v2 of patch 2/3, in case you might want to take a look: https://github.com/matheustavares/git/commit/970ef529f1e8f719c4427bd9fea8205ada69d913