Carlo Marcelo Arenas Belón <carenas@xxxxxxxxx> writes: > On Thu, Apr 23, 2020 at 11:43:17PM +0000, Johannes Schindelin via GitGitGadget wrote: >> diff --git a/credential.c b/credential.c >> index 52965a5122c..3505f6356d8 100644 >> --- a/credential.c >> +++ b/credential.c >> @@ -53,7 +53,13 @@ static int credential_config_callback(const char *var, const char *value, >> char *url = xmemdupz(key, dot - key); >> int matched; >> >> - credential_from_url(&want, url); >> + if (credential_from_url_gently(&want, url, 1, 0) < 0) { > > definitely not worth a reroll, but just wondering if would make sense to call > credential_from_url_gently(!quiet) here, just for consistency? Speaking of which, it is not clear which one of "...url, 1, 0)" is the "quiet" bit. I somehow thought that somebody suggested to roll these two into a flags word and give quiet and the other bit a name, and after seeing this line, I tend to agree that would be great for readability. > other than that this series is looking great, under the assumption that there > is going to be some more followup with non essential changes. > > will chip in with an test helper for that series so we can hopefully keep our > sanity next time someone touches that function again. Thanks, everybody, for help polishing this topic.