On Fri, Apr 10, 2020 at 05:10:32PM +0200, Martin Ågren wrote: > Instead of using `starts_with()`, the magic number 7, `strlen()` and a > fair number of additions to verify the three parts of the config key > "branch.<branch>.mergeoptions", use `skip_prefix()` to jump through them > more explicitly. The conversion looks correct to me and is certainly an improvement. > We need to introduce a new variable for this (we certainly can't modify > `k` just because we see "branch."!). With `skip_prefix()` we often use > quite bland names like `p` or `str`. Let's do the same. If and when this > function needs to do more prefix-skipping, we'll have a generic variable > ready for this. I was about to comment on this in the patch, but your explanation preempted me. :) The logic here makes sense. > diff --git a/builtin/merge.c b/builtin/merge.c > index d127d2225f..bde5f14f05 100644 > --- a/builtin/merge.c > +++ b/builtin/merge.c > @@ -597,10 +597,10 @@ static void parse_branch_merge_options(char *bmo) > static int git_merge_config(const char *k, const char *v, void *cb) > { > int status; > + const char *str; > > - if (branch && starts_with(k, "branch.") && > - starts_with(k + 7, branch) && > - !strcmp(k + 7 + strlen(branch), ".mergeoptions")) { > + if (branch && skip_prefix(k, "branch.", &str) && > + skip_prefix(str, branch, &str) && !strcmp(str, ".mergeoptions")) { > free(branch_mergeoptions); > branch_mergeoptions = xstrdup(v); > return 0; In general, parsing subsections accurately involves looking from both the start and the end of the string, pulling out the section and key and leaving the rest in the middle. But I think we can get away with this left-to-right parsing because we're only interested in matching a _specific_ subsection name, and a specific key. So there are no cases it will handle incorrectly. The more general form would be: const char *subsection, *key; int subsection_len; if (!parse_config_key("branch", &subsection, &subsection_len, &key) && subsection_len == strlen(branch) && !strncmp(subsection, branch) && !strcmp(key, "mergeoptions")) ... but that's a bit more awkward (it would be less so if we had a helper function for comparing a NUL-terminated string against a ptr/len pair). -Peff