>From Jeff King, Mon 02 Mar 2020 at 08:48:42 (-0500) : > And I think all of this may be duplicated with git-push itself (which > would also be nice to get rid of, but last time I looked into it was > hard to refactor it to do so). I had a quick look at git-push but the duplication does not seems too bad. > > In the 'upstream' case, the auxiliary function would return > > branch->merge_name[0]. So the question is: can > > tracking_for_push_dest(branch->merge_name[0]) be different from > > branch->merge[0]->dst? > Those will both return tracking refs. I think you just want > merge[0]->src for the upstream case. > And yes, the two can be different. It's the same case as when the > upstream branch has a different name than the current branch. I meant, now that we have branch_get_push_remoteref, can we replace the body of branch_get_push_1 by remote = remote_get(pushremote_for_branch(branch, NULL)); ret = tracking_for_push_dest(remote, branch_get_push_remoteref(branch), err); (we would need to add error handling in branch_get_push_remoteref but that is easy) Currently that is exactly what branch_get_push_1 does, except in the PUSH_DEFAULT_UPSTREAM where it returns branch->merge[0]->dst. But branch->merge is set up in `set_merge`, where we have: ret->merge[i]->src = xstrdup(ret->merge_name[i]); ... if (dwim_ref(ret->merge_name[i], strlen(ret->merge_name[i]), &oid, &ref) == 1) ret->merge[i]->dst = ref; So my question was: can dwim_ref(branch->merge[0]->src) be different from tracking_for_push_dest(branch->merge[0]->src)? > Yeah, I think that's going to be the easiest. It would be nice to avoid > repeating that switch(), but frankly I think the boilerplate you'll end > up with trying to handle the two cases may be worse than just repeating > it. That's what I went with. We can always refactorise branch_get_push_1 to use branch_get_push_remoteref afterwards. > It may be worth adding a comment to each function to mention the > other, and that any changes need to match. I tried to add a comment, but I don't know if it is helpful enough.