On 2/6/2020 7:48 PM, Emily Shaffer wrote: > Since 'err' contains output for multiple submodules and is printed all > at once by fetch_populated_submodules(), errors for each submodule > should be newline separated for readability. The same strbuf is added to > with a newline in the other half of the conditional where this error is > detected, so make the two consistent. A worthy goal, and thanks for pointing out that this matches the "Fetching submodule %s%s\n" string in the other block. > - _("Could not access submodule '%s'"), > + _("Could not access submodule '%s'\n"), My initial thought was that this `\n` should be added in front of the string, and only if the string has existing data. However, that's not what happens in the other block, so doing it that way would require changing both places. This approach is also less error-prone, even if it may result in an "extra" newline at the end of all the messages. LGTM. Thanks, -Stolee