Martin Nicolay <m.nicolay@xxxxxxxxx> writes: > The new function get_files_lock_timeout_ms reads the config > core.filesLockTimeout similar to get_files_ref_lock_timeout_ms. > This value is used in hold_lock_file_for_update instead of the > fixed value 0. > > While working with complex scripts invoking git multiple times > my editor (emacs with standard version control) detects the > changes and apparently calls "git status". This leads to abort > in "git stash". With this patch and an appropriate value > core.filesLockTimeout this problem goes away. > > While it may be possible to patch the elisp scripts of emacs (and > all other similar callers) to call "git status" with > --no-optional-locks it seems to me a better approarch to solve this > problem at its root: calling hold_lock_file_for_update_timeout with > a timeout of 0 ms. > > The implementation with the function get_files_lock_timeout_ms is > adopted from a similar usage of get_files_ref_lock_timeout_ms. > --- Missing sign-off before the three-dash line. I think the last paragraph can be left without. It is not like there are many other sensible ways to get a configured value without making repeated calls to git_config_get_int(). > +core.filesLockTimeout:: > + The length of time, in milliseconds, to retry when trying to > + lock an individual file. Value 0 means not to retry at > + all; -1 means to try indefinitely. Default is 0 (i.e., don't > + retry at all). Will there be *NO* callers of the lockfile API functions that do not honor the value taken from this configuration variable after this patch is applied? Otherwise, users who set this configuration variable and hit a codepath that locks files without asking get_files_lock_timeout_ms() how it should retry would find the above description inaccurate, wouldn't they? There is another question---is it safe to make all attempts to create a lockfile retry, possibly forever? I do not offhand think of any concrete example, but I would not be surprised if there is a codepath that would never want to retry but want to fail upon the first failure (i.e. wants to always use value 0 without allowing the users to configure). So, unless the answers to the above two questions are "with this patch, all attempts to lock will honor this variable" and "yes it is safe because ...", some tweak of the description may be necessary to hint the readers that not all the locks will retry by honoring this variable. > diff --git a/lockfile.c b/lockfile.c > index 8e8ab4f29f..7301f393d6 100644 > --- a/lockfile.c > +++ b/lockfile.c > @@ -145,6 +145,22 @@ static int lock_file_timeout(struct lock_file *lk, const char *path, > } > } > > +/* > + * Get timeout for hold_lock_file_for_update. > + */ > +long get_files_lock_timeout_ms(void) Shouldn't this return "int", which is the type you get from the underlying configuration API? I also wondered if this has to be extern at all; the reason why this patch makes it extern is purely because hold_lock_file_for_update() is defined as a static inline in lockfile.h to expand to another function, so any file that includes lockfile.h and calls that static inline must be able to see this name. Because all of the lockfile public API functions are about accessing filesystem entities, I am not sure if making this many thin wrappers static inlines to potentially save one extra intermediate call is worth it (there are 10 of them). For now, I think the organization this patch leaves is OK, but we may later want to examine these static inline wrappers and consider turning them into a regular extern functions. I do not think other static inline wrappers in the lockfile.h is hurting right now, but with this change, hold_lock_file_for_update() certainly is. If it becomes just a usual extern function, we do not have to expose the get-files-lock-timeout-ms helper at all (and worry about its name, as globally visible names needs extra care to help developers). In any case, that is outside the scope of this patch, but a potential follow-on work after this patch stabilizes. > +{ > + static int configured = 0; > + > + static int timeout_ms = 0; /* default */ > + if (!configured) { - Do not explicitly initialize statics to zero (instead, let BSS take care of it). - Lose the blank line between the declarations. - Have a blank line after the last decl and the first statement. > + git_config_get_int("core.fileslocktimeout", &timeout_ms); > + configured = 1; > + } > + > + return timeout_ms; > +} By the way, why are these called file*S*locktimeout (both the end-user facing configuration variable and the function name)? Also, "lock timeout" is a misleading name for both the configuration variable and the function. It sounds as if after that many milliseconds, the system will automatically break your lock if you do not perform the action under the lock quickly enough, but that is a wrong message to send to the end users. The timeout is about retrying to acquire the lock, so the name most likely needs to have words "lock", "retry", and "timeout" somewhere in it. Perhaps core.lockRetryTimeout or something? I dunno. You may want to wait before others offer a better name before rerolling, as I am not very good at naming things. Thanks.