Use strip_suffix() instead of open-coding it, making the code more idiomatic. Signed-off-by: SZEDER Gábor <szeder.dev@xxxxxxxxx> --- builtin/name-rev.c | 8 ++++---- 1 file changed, 4 insertions(+), 4 deletions(-) diff --git a/builtin/name-rev.c b/builtin/name-rev.c index c785fe16ba..d345456656 100644 --- a/builtin/name-rev.c +++ b/builtin/name-rev.c @@ -317,11 +317,11 @@ static const char *get_rev_name(const struct object *o, struct strbuf *buf) if (!n->generation) return n->tip_name; else { - int len = strlen(n->tip_name); - if (len > 2 && !strcmp(n->tip_name + len - 2, "^0")) - len -= 2; + size_t len; + strip_suffix(n->tip_name, "^0", &len); strbuf_reset(buf); - strbuf_addf(buf, "%.*s~%d", len, n->tip_name, n->generation); + strbuf_addf(buf, "%.*s~%d", (int) len, n->tip_name, + n->generation); return buf->buf; } } -- 2.23.0.331.g4e51dcdf11