On Sat, Jul 13, 2019 at 03:22:03PM -0700, Carlo Arenas wrote: > On Sat, Jul 13, 2019 at 2:29 PM Junio C Hamano <gitster@xxxxxxxxx> wrote: > > > > I wish if we could say > > > > struct patch patch = {}; > > that is actually a GNU extension that is supported by gcc and clang (at least) > and that sparse also recognizes as valid; it is also valid C++ so it might be > even supported by MSVC. > > it will obviously trigger warnings if using pedantic mode and is IMHO not worth > the hassle to maintain in a portable codebase like git, but also wish could be > added to C2X I wonder if we could come up with a definition of INIT_ZERO such that: struct foo bar = { INIT_ZERO }; worked everywhere. IMHO that is more readable than "{}" anyway. In GNU-compatible compilers, it is just: #define INIT_ZERO Unfortunately I can't think of a fallback that would work universally. It cannot just be "0", as we run into the NULL thing (not to mention when the first member is itself a struct). It does not help us to add an explicit cast, because the type of the cast is dependent on the context in which the macro is used. Nor do I think typeof() could save us (if we could even assume it exists everywhere we need the fallback, which we almost certainly can't). But it does seem a real shame there is no way to say "zero-initialize this struct" in C without providing at least a single member value. Ordering struct definitions to put an arithmetic type at the start is an OK workaround (to just let "0" work everywhere). But it does fall down when the first element _has_ to be a struct (like, say, any user of our hashmap.[ch] interface). -Peff