Hi Peff, On Fri, 24 May 2019, Jeff King wrote: > On Thu, May 23, 2019 at 09:12:27AM +0200, Johannes Schindelin wrote: > > > > + echo no-conflict >expect && > > > + git log -1 --format=%s >actual && > > > + test_cmp expect actual > > > > I would prefer > > > > test no-conflict = "$(git show -s --format=%s HEAD)" > > > > or even better: > > > > test_cmp_head_oneline () { > > if test "$1" != "$(git show -s --format=%s HEAD)" > > then > > echo >&4 "HEAD's oneline is '$(git show -s \ > > --format=%s HEAD)'; expected '$1'" > > return 1 > > fi > > } > > This, I disagree with. IMHO comparing command output using "test" is > harder to read and produces worse debugging output (unless you do a > helper as you showed, which I think makes the readability even worse). > Not to mention that it raises questions of the shell's whitespace > handling (though that does not matter for this case). > > What's your complaint with test_cmp? Is it the extra process? Could we > perhaps deal with that by having it use `read` for the happy-path? I would prefer it if we adopted a more descriptive style in the test suite, as I always found that style to be much easier to work with (you might have guessed that I am spending a lot of time chasing test failures). Succinctness is just one benefit of that. A more important benefit is that you can teach a helper that verifies onelines to show very useful information in case of a failure, something that `test_cmp` cannot do because it is totally agnostic to what it compares. > Or do you prefer having a one-liner? I'd rather come up with a more > generic helper to cover this case, that can run any command and compare > it to a single argument (or stdin). E.g.,: > > test_cmp_cmd no-conflict git log -1 --format=%s > > or > > test_cmp_cmd - git foo <<-\EOF > multi-line > expectation > EOF I guess that you and me go into completely opposite directions here. I want something *less* general. Because I want to optimize for the unfortunate times when a test fails and most likely somebody else than the original author of the test case is tasked with figuring out what the heck goes wrong. You seem to want to optimize for writing test cases. Which I find -- with all due respect -- the wrong thing to optimize for. It is already dirt easy to write new test cases. But *good* test cases (i.e. easy to debug ones)? Not so much. > But I'd rather approach those issues separately and systematically, and > not hold up this bug fix. Sure. > > > +test_expect_success 'interactive am can resolve conflict' ' > > > + git reset --hard base && > > > + printf "%s\n" y y | test_must_fail git am -i mbox && > > > + echo resolved >file && > > > + git add -u && > > > + printf "%s\n" v y | git am -i --resolved && > > > > Maybe a comment, to explain to the casual reader what the "v" and the "y" > > are supposed to do? > > OK. The "v" is actually optional, but I figured it would not hurt to > have us print the patch we just generated. I'll add a comment. Thank you. Ciao, Dscho