Denton Liu <liu.denton@xxxxxxxxx> writes: > - new_branch_info->name = arg; > + new_branch_info->name = strstr(arg, "...") ? > + xstrdup(oid_to_hex(rev)) : > + arg; Can we do better? I am not sure why we want to hardcode the knowledge of "..." syntax like this here. "git checkout A...B" introduced in 2009 needed only a single-liner change from get_sha1() to get_sha1_mb() without making the ugly implementation detail seep into this layer.