On Thu, Apr 25, 2019 at 7:16 AM Junio C Hamano <gitster@xxxxxxxxx> wrote > * en/unicode-in-refnames (2019-04-24) 1 commit > - Honor core.precomposeUnicode in more places > > The names of the refs stored as filesystem entities may become > different from what the end-user expects, just like files in the > working tree gets "renamed", on a filesystem like HFS+. Work it > around by paying attemption to the core.precomposeUnicode > configuration. > > Looked sensible. Ready for next? Almost. Torsten pointed out that I left some commentary in the commit message that I should remove. I'll send a v2 with it excised. Also, s/it around/around it/ and s/attemption/attention/ in your summary? > * nd/switch-and-restore (2019-04-12) 43 commits > - help: move git-diff and git-reset to different groups > - rm: add --staged as alias for --cached > - doc: promote "git restore" > - user-manual.txt: prefer 'merge --abort' over 'reset --hard' > - completion: support restore > - t: add tests for restore > - restore: support --patch > - restore: replace --force with --ignore-unmerged > - restore: default to --source=HEAD when only --staged is specified > - restore: reject invalid combinations with --staged > - restore: add --worktree and --staged > - checkout: factor out worktree checkout code > - restore: disable overlay mode by default > - restore: make pathspec mandatory > - restore: take tree-ish from --source option instead > - checkout: split part of it to new command 'restore' > - doc: promote "git switch" > - completion: support switch > - t: add tests for switch > - switch: make --orphan switch to an empty tree > - switch: reject if some operation is in progress > - switch: no worktree status unless real branch switch happens > - switch: implicit dwim, use --no-guess to disable it > - switch: add short option for --detach > - switch: only allow explicit detached HEAD > - switch: reject "do nothing" case > - switch: stop accepting pathspec > - switch: remove -l > - switch: add --discard-changes > - switch: better names for -b and -B > - checkout: split part of it to new command 'switch' > - checkout: split options[] array in three pieces > - checkout: move 'confict_style' and 'dwim_..' to checkout_opts > - checkout: make "opts" in cmd_checkout() a pointer > - checkout: factor out some code in parse_branchname_arg() > - checkout: keep most #include sorted > - checkout: inform the user when removing branch state > - checkout: advice how to get out of detached HEAD mode > - t: rename t2014-switch.sh to t2014-checkout-switch.sh > - git-checkout.txt: fix monospace typeset > - doc: document --overwrite-ignore > - git-checkout.txt: fix one syntax line > - git-checkout.txt: spell out --no-option > > Two new commands "git switch" and "git restore" are introduced to > split "checking out a branch to work on advancing its history" and > "checking out paths out of the index and/or a tree-ish to work on > advancing the current history" out of the single "git checkout" > command. > > The "switch" part seems more or less ready for testing. Perhaps > we should split this back into two topics and merge it to 'next'. > cf. <20190329103919.15642-1-pclouds@xxxxxxxxx> (switch v6) > cf. <20190411131218.19195-1-pclouds@xxxxxxxxx> (restore v2) Splitting apart and advancing "switch" makes sense to me. I'm behind on stuff but really need to take a look at the new restore series; I'll try to get to that soon.