Josh Steadmon <steadmon@xxxxxxxxxx> writes: > diff --git a/t/t0210-trace2-normal.sh b/t/t0210-trace2-normal.sh > index 03a0aedb1d..26c9c1b3b8 100755 > --- a/t/t0210-trace2-normal.sh > +++ b/t/t0210-trace2-normal.sh > @@ -80,6 +80,21 @@ test_expect_success 'normal stream, return code 1' ' > test_cmp expect actual > ' > > +test_expect_success 'randomized filename' ' > + test_when_finished "rm -r traces actual expect" && > + mkdir traces && > + GIT_TR2="$(pwd)/traces" test-tool trace2 001return 0 && > + perl "$TEST_DIRECTORY/t0210/scrub_normal.perl" <"$(ls traces/*)" >actual && This is cute. What we want to test for this new feature is that the directory traces/ that was originally empty now has exactly one readable file, which was created by producing a trace. And redirecting from "$(ls traces/*)" would succeed only when there is exactly one readble file in the directory. If it has none, or more than one, the redirection will fail and we'd notice the error. > + cat >expect <<-EOF && > + version $V > + start _EXE_ trace2 001return 0 > + cmd_name trace2 (trace2) > + exit elapsed:_TIME_ code:0 > + atexit elapsed:_TIME_ code:0 > + EOF > + test_cmp expect actual > +' > + > # Verb 002exit > # > # Explicit exit(code) from within cmd_<verb> propagates <code>. > diff --git a/trace2/tr2_dst.c b/trace2/tr2_dst.c > index fd490a43ad..0e752914dc 100644 > --- a/trace2/tr2_dst.c > +++ b/trace2/tr2_dst.c > @@ -1,5 +1,6 @@ > #include "cache.h" > #include "trace2/tr2_dst.h" > +#include "trace2/tr2_sid.h" > > /* > * If a Trace2 target cannot be opened for writing, we should issue a > @@ -12,6 +13,11 @@ > */ > #define TR2_ENVVAR_DST_DEBUG "GIT_TR2_DST_DEBUG" > > +/* > + * How many attempts we will make at creating a random trace output path. > + */ > +#define MAX_RANDOM_ATTEMPTS 10 With the updated design, randomness is no longer the primary property of this new feature. The fact that the names are automatically assigned is. It could be that the source of tr2_sid may (or may not) be some randomness, but the point is that the caller in this patch does not care how tr2_sid is computed. I'd call this max-attempts (or max-autopath-attempts, but that is rather long, and I do not think inside the scope of "tr2_dst" that is about "destination", there will be anything but the destination path we'd "attempt" with a reasonable maximum value to compute, so the "-autopath" clarification would not buy us much).... > static int tr2_dst_want_warning(void) > { > static int tr2env_dst_debug = -1; > @@ -36,6 +42,53 @@ void tr2_dst_trace_disable(struct tr2_dst *dst) > dst->need_close = 0; > } > > +static int tr2_dst_try_random_path(struct tr2_dst *dst, const char *tgt_prefix) .... and I'd call this s/random/auto/ instead, if I were writing this patch following the updated design. > +{ > + int fd; > + const char *last_slash, *sid = tr2_sid_get(); > + struct strbuf base_path = STRBUF_INIT, final_path = STRBUF_INIT; > + unsigned attempt_count; > + > + last_slash = strrchr(sid, '/'); > + if (last_slash) > + sid = last_slash + 1; > + > + strbuf_addstr(&base_path, tgt_prefix); > + if (!is_dir_sep(base_path.buf[base_path.len - 1])) > + strbuf_addch(&base_path, '/'); > + strbuf_addstr(&base_path, sid); I do not think it is such a huge deal, but you can remember the value of base_path.len at this point and then get rid of the other strbuf (and copying into it). As that will leave only one path variable you need to worry about, you can shorten base_path to just path if you go that route. baselen = path.len; > + for (attempt_count = 0; attempt_count < MAX_RANDOM_ATTEMPTS; attempt_count++) { > + strbuf_reset(&final_path); > + strbuf_addbuf(&final_path, &base_path); > + strbuf_addf(&final_path, ".%d", attempt_count); > + fd = open(final_path.buf, O_WRONLY | O_CREAT | O_EXCL, 0666); If you follow the "get rid of final_path" route, these would become: strbuf_setlen(&path, baselen); strbuf_addf(&path, ".%d", count); fd = open(path.buf, ..., 0666); > + if (fd != -1) > + break; > + } And that way, you have one fewer strbuf to _release() at the end and at early exit points. > + if (tr2_dst_want_warning()) > + warning("trace2: could not open '%s' for '%s' tracing: %s", > + base_path.buf, dst->env_var_name, strerror(errno)); This would need to become warning("trace2: could not open '%.*s' for '%s' tracing: %s", path.buf, baselen, dst->env_var_name, strerror(errno)); if we go that route.