On Fri, Feb 22, 2019 at 04:05:45PM +0000, Olga Telezhnaya wrote: > Start using ref_format struct instead of simple char*. > Need that for further reusing of formatting logic from ref-filter. Makes sense. > struct batch_options { > + struct ref_format format; > int enabled; > int follow_symlinks; > int print_contents; > @@ -24,7 +26,6 @@ struct batch_options { > int all_objects; > int unordered; > int cmdmode; /* may be 'w' or 'c' for --filters or --textconv */ > - const char *format; > }; Not a huge deal, but unless there's a compelling reason to move the field around in the struct, the diff is easier to read if the deleted and added lines stay in the same place. > @@ -491,9 +492,6 @@ static int batch_objects(struct batch_options *opt) > int save_warning; > int retval = 0; > > - if (!opt->format) > - opt->format = "%(objectname) %(objecttype) %(objectsize)"; > - This assignment moves down to cmd_cat_file(). I don't see any reason that shouldn't work, but it makes reviewing easier if there aren't unexpected changes (so if it doesn't need moved in the grand scheme of things, leave it as it was; if it does, it should either come in its own patch, or get a note in the commit message as to why it needed to move). -Peff