On Wed, Jan 30, 2019 at 4:49 AM Nguyễn Thái Ngọc Duy <pclouds@xxxxxxxxx> wrote: > The shortcut of these options do not make much sense when used with > switch. And their descriptions are also tied to checkout > out. Move -b/-B to cmd_checkout() and new -c/-C with the same > functionality in cmd_switch_branch() > > Signed-off-by: Nguyễn Thái Ngọc Duy <pclouds@xxxxxxxxx> > --- > diff --git a/builtin/checkout.c b/builtin/checkout.c > @@ -1353,14 +1353,10 @@ static struct option *add_common_options(struct checkout_opts *opts, > @@ -1556,15 +1552,22 @@ static int checkout_main(int argc, const char **argv, const char *prefix, > int cmd_checkout(int argc, const char **argv, const char *prefix) > { > + struct option checkout_options[] = { > + OPT_STRING('b', NULL, &opts.new_branch, N_("branch"), > + N_("create and checkout a new branch")), > + OPT_STRING('B', NULL, &opts.new_branch_force, N_("branch"), > + N_("create/reset and checkout a branch")), Note wording for -B and compare with... > @@ -1577,14 +1580,21 @@ int cmd_switch(int argc, const char **argv, const char *prefix) > + struct option switch_options[] = { > + OPT_STRING('c', "create", &opts.new_branch, N_("branch"), > + N_("create and switch to a new branch")), > + OPT_STRING('C', "force-create", &opts.new_branch_force, N_("branch"), > + N_("create/reset and switch to a new branch")), wording for -C which talks about "new branch" rather than just "branch" of -B. (Dropping "new" from the latter makes it read a bit better, in my opinion, and would make it consistent with -B wording.) > + OPT_END() > + };