Johannes Schindelin <Johannes.Schindelin@xxxxxx> writes: >> > static int reset_head(struct object_id *oid, const char *action, >> > - const char *switch_to_branch, int detach_head, >> > + const char *switch_to_branch, >> > + int detach_head, int reset_hard, >> >> It might be worth switching to a single flag variable here. It would >> make calls like this: >> >> > - if (reset_head(&options.onto->object.oid, "checkout", NULL, 1, >> > + if (reset_head(&options.onto->object.oid, "checkout", NULL, 1, 0, >> > NULL, msg.buf)) >> >> a little more self-documenting (if a little more verbose). > > I thought about that, but for just two flags? Well, let me try it and see > whether I like the result ;-) My rule of thumb is that repeating three times is definitely when we should consolidate separate ones into a single flag word, and twice is a borderline. For two-time repetition, it is often worth fixing when somebody notices it during the review, as that is a sign that repetition, even a minor one, disturbed a reader enough to point out. On the other hand, for a file-scope static that is likely to stay as a non-API function but a local helper, it may not be worth it. So I am OK either way, slightly in favor of fixing it while we remember. >> This one could actually turn into: >> >> ret = error(...); >> goto leave_reset_head; >> >> now. We don't have to worry about an uninitialized desc.buffer anymore >> (as I mentioned in the previous email), because "nr" would be 0. >> >> It doesn't save any lines, though (but maybe having a single >> cleanup/exit point would make things easier to read; I dunno). > > But you're right, of course. Consistency makes for easier-to-read code. Yup, that does sound good. Thanks.