Torsten Bögershausen <tboegi@xxxxxx> writes: >> +static int stream_blob(const struct object_id *oid) > > Sorry for nit-picking: > could this be renamed into stream_blob_to_stdout() ? I think that name makes sense, even though stream_blob() is just fine for a fuction that takes a single parameter oid, as there is no other sane choice than streaming to the standard output stream the blob data. >> +{ >> + if (stream_blob_to_fd(1, oid, NULL, 0)) > > And I wonder if we could make things clearer: > s/1/STDOUT_FILENO/ What would benefit from symbolic constant more in that function call may be CAN_SEEK thing, but s/1/STDOUT_FILENO/ adds negative value to that line, I would think. The name of the function already makes it clear this is sending the output to a file descriptor, and an integer 1 that specifies a file descriptor cannot mean anything other than the standard output stream.