Josh Triplett <josh@xxxxxxxxxxxxxxx> wrote: > Linus Torvalds wrote: > > That said, the whole "prepend 'x' to the function name" thing is obviously > > how git does things, but maybe it would be more readable in the long term > > to make the prefix be 'safe_' instead of 'x', or something like that? > > If you want a more verbose name than xfoo, I personally like the foo_or_die > convention, which reminds you explicitly that the function might kill the > program. safe_ might convey exactly the opposite impression. I think the _gently suffix is already preferred for the non-die()'ing variant of a function within Git. For example see setup_git_directory_gently() or lookup_commit_reference_gently(). Of course pkt-line.c goes and defines safe_read/safe_write. And lets not forget about safe_create_dir() and safe_create_leading_directories(). I guess we're about half-way in both directions. Next function declared with safe_ prefix or _gently suffix will tip the scale in one direction or the other. ;-) -- Shawn. - To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html