Re: [PATCH] config.mak.dev: enable -Wunused-function

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Thu, Oct 18, 2018 at 05:48:16PM +0200, Duy Nguyen wrote:

> >   - conditional compilation, where we may or may not need a
> >     static helper. These generally fall into one of two
> >     categories:
> >
> >       - the call should not be conditional, but rather the
> >         function body itself should be (and may just be a
> >         no-op on one side of the #if). That keeps the
> >         conditional pollution out of the main code.
> >
> >       - call-chains of static helpers should all be in the
> >         same #if block, so they are all-or-nothing
> 
> Grouping is not always desired because it could break better function
> layout. Have a look at read-cache.c where _ieot_extension functions
> are #if'd because the only call sites are from pthread code (#if'd far
> away).

True, though as long as they are triggered by the same set of #if
conditions, that is fine. Putting them in the same block  is just an
easy way to make sure that is the case. ;)

> In this particular case though I think we should be able to avoid so
> much #if if we make a wrapper for pthread api that would return an
> error or something when pthread is not available. But similar
> situation may happen elsewhere too.

Yeah, I think that is generally the preferred method anyway, just
because of readability and simplicity.

> Having said that, if people do consider MAYBE_UNUSED before #if'ing
> everywhere (and opening up more conditional build problems in future),
> I think this change is fine.

I'd like to use it as a last resort, certainly. Mostly the fact that we
compile cleanly _now_ makes me think that it probably won't be that hard
to keep it going.

I think the biggest potential problem with this is going to be obscure
configurations where some functions are used or not used. So somebody
silencing a compiler warning may inadvertently break another case if
they're not careful. But that's already a problem to some degree (and
part of why we try to push the conditionality out to the whole-function
level).

-Peff



[Index of Archives]     [Linux Kernel Development]     [Gcc Help]     [IETF Annouce]     [DCCP]     [Netdev]     [Networking]     [Security]     [V4L]     [Bugtraq]     [Yosemite]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Linux SCSI]     [Fedora Users]

  Powered by Linux