On Fri, Aug 3, 2018 at 12:55 AM, Stefan Beller <sbeller@xxxxxxxxxx> wrote: > On Wed, Aug 1, 2018 at 11:16 PM Christian Couder > <christian.couder@xxxxxxxxx> wrote: >> >> From: Christian Couder <christian.couder@xxxxxxxxx> >> >> Signed-off-by: Junio C Hamano <gitster@xxxxxxxxx> >> --- >> Documentation/config.txt | 5 +++++ >> 1 file changed, 5 insertions(+) >> >> diff --git a/Documentation/config.txt b/Documentation/config.txt >> index 43b2de7b5f..2d048d47f2 100644 >> --- a/Documentation/config.txt >> +++ b/Documentation/config.txt >> @@ -2513,6 +2513,11 @@ This setting can be overridden with the `GIT_NOTES_REWRITE_REF` >> environment variable, which must be a colon separated list of refs or >> globs. >> >> +odb.<name>.promisorRemote:: >> + The name of a promisor remote. For now promisor remotes are >> + the only kind of remote object database (odb) that is >> + supported. >> + > > Can you explain the end goal for this? (I did not find it in the cover letter, > nor do I make sense of this documentation) First thank you for (re)opening this discussion, as I think it may help resolve the issues related to my work. In the cover letter there is a "Discussion" section which is about this, but I agree that it might not be very clear. The main issue that this patch series tries to solve is that extensions.partialclone config option limits the partial clone and promisor features to only one remote. One related issue is that it also prevents to have other kind of promisor/partial clone/odb remotes. By other kind I mean remotes that would not necessarily be git repos, but that could store objects (that's where ODB, for Object DataBase, comes from) and could provide those objects to Git through a helper (or driver) script or program. For reference I tried to raise these issues (especially the first one) at least twice before extensions.partialclone was merged: https://public-inbox.org/git/CAP8UFD3Jt+0Lq9Yx_7x3sJD+jG+A25bAgDg7zp+dZV43+1-vow@xxxxxxxxxxxxxx/ https://public-inbox.org/git/CAP8UFD0P7kVo2NP4Wq7OaSV4H1+sqHapuzW5AQef+enNS0S5hw@xxxxxxxxxxxxxx/ but it was still merged as is. (So of course now it's not surprising that my work on this patch series keeps conflicting with work that is still going on promisors and partial clone, and unfortunately the result is that my work keeps being ejected from pu when it can reach it.) > So from what I understand, this series relates to partialClone, which > has the remote name of the "promisor" in extensions.partialclone. > That is the remote to contact for any needs w.r.t. partial clone and > fetching on demand. Yes. > This key "odb.<name1>.promisorRemote = <name2>" introduces > 2 new names, where do each of these two names hook in? > name2 is a remote, such as "origin" from what I can tell, but > which naming scheme does name1 follow here? There is just one new name. Instead of: extensions.partialclone = <remote name> there is: odb.<remote odb name>.promisorRemote = <remote name> So it is now like: remote.<remote name>.url = <remote url> which we use for remote repositories. And it enables us to: - have more than one promisor remote - specify different parameters for each promisor remote - make it possible later to have other kind of promisor/odb remotes It also restores the distributed nature of Git which was kind of broken for promisor remotes. > What makes the odb key different, in that the partial clone > feature only handles objects as well? I am not sure I understand this question. Anyway if we want more than one promisor remote, we need to be able to specify different parameters for each promisor remote. For example now core.partialclonefilter is used to specify some filters for the promisor remote, but how can we nicely specify different partial clone filters if we have more than one promisor remote? With the changes in this patch series core.partialclonefilter is replaced with odb.<remote odb name>.partialclonefilter, so that parameters for a remote odb are properly grouped together in the section where the remote odb is defined. One alternative scheme could be for example to have: remote.<remote name>.promisor = (true|false) or maybe: remote.<remote name>.partialclone = (true|false) instead of: extensions.partialclone = <remote name> And then we could also have: remote.<remote name>.partialclonefilter = <partial clone filter> The issue with this scheme is that it kind of overloads the "remote.<remote name>.*" namespace for something that can be seen as different especially if, as I want to do it later, we are going to have other kind of promisor/odb remotes. I plan to send a V5 of this patch series really soon now, where I will try to explain better the end goal.