Re: [PATCH v2 24/24] Rename functions to avoid breaking in-flight topics

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Nguyễn Thái Ngọc Duy  <pclouds@xxxxxxxxx> writes:

> The three functions init_revisions(), diff_setup() and rerere() are
> prefixed temporarily with repo_ to avoid breaking other topics which
> add new call sites for these functions. This is a temporary
> measure. Once everything is merged, it will be reverted and the new
> call sites fixed.

That's a sensible thing to do, but isn't it too late at 24/24 stage?
IOW, doesn't in-flight topics break if up to 23/24 of this series is
merged?

IOW, the one that teaches "work in this repository" to rerere(int)
for example should have introduced

	repo_rerere(struct repository *, int);
	#define rerere(x) repo_rerere(the_repository, x)

in its own step, not this late in the series, no?

> diff --git a/apply.c b/apply.c
> index fc52993548..fdae1d423b 100644
> --- a/apply.c
> +++ b/apply.c
> @@ -4632,7 +4632,7 @@ static int write_out_results(struct apply_state *state, struct patch *list)
>  		}
>  		string_list_clear(&cpath, 0);
>  
> -		rerere(state->repo, 0);
> +		repo_rerere(state->repo, 0);
>  	}
>  
>  	return errs;



[Index of Archives]     [Linux Kernel Development]     [Gcc Help]     [IETF Annouce]     [DCCP]     [Netdev]     [Networking]     [Security]     [V4L]     [Bugtraq]     [Yosemite]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Linux SCSI]     [Fedora Users]

  Powered by Linux