On Fri, 24 Aug 2018 16:32:38 +0200 Ævar Arnfjörð Bjarmason <avarab@xxxxxxxxx> wrote: > > On Fri, Aug 24 2018, Antonio Ospite wrote: [...] > > +static int config_print_callback(const char *key_, const char *value_, void *cb_data) > > +{ > > + char *key = cb_data; > > + > > + if (!strcmp(key, key_)) > > + printf("%s\n", value_); > > + > > + return 0; > > +} > > No problem with the code itself, but I'd find this a lot easier to read > in context if it was: > > key_ -> var > value_ -> value > key -> wanted_key, perhaps? > > I.e. the rest of the file uses the convention of the > config_from_gitmodules callbacks getting "var" and "value", > respectively. > > We don't use this convention of suffixing variables with "_" if they're > arguments to the function anywhere else. > I was new to git when I firstly wrote the code, I picked up the style by copying from builtin/config.c (collect_config() and show_all_config()) because I was focusing more on the functionality and didn't bother to harmonize the style with the destination file. > > +int print_config_from_gitmodules(const char *key) > > +{ > > + int ret; > > + char *store_key; > > + > > + ret = git_config_parse_key(key, &store_key, NULL); > > + if (ret < 0) > > + return CONFIG_INVALID_KEY; > > Isn't this a memory leak? I.e. we should free() and return here, no? > It is true that git_config_parse_key_1() allocates some storage even for an invalid key, and uses the space to lowercase the key as the parsing progresses, however it also frees the memory in the *error* path. So unless I am missing something I don't think there is a leak here. [...] > > diff --git a/submodule-config.h b/submodule-config.h > > index dc7278eea4..ed40e9a478 100644 > > --- a/submodule-config.h > > +++ b/submodule-config.h > > @@ -56,6 +56,8 @@ void submodule_free(struct repository *r); > > */ > > int check_submodule_name(const char *name); > > > > +int print_config_from_gitmodules(const char *key); > > + > > /* > > * Note: these helper functions exist solely to maintain backward > > * compatibility with 'fetch' and 'update_clone' storing configuration in > > Another style nit: Makes more sense to put this new function right > underneath "submodule_free" above, instead of under 1/2 of the functions > that have a big comment describing how they work, since that comment > doesn't apply to this new function. You are probably right, IIRC the function was firstly written before check_submodule_name() was there. And I didn't think of moving it up when I rebased after check_submodule_name() was added. Your same remark may apply to the new function added in patch 02. I'll wait for other comments to see if a v5 is really needed. Thanks for the review Ævar. Ciao, Antonio -- Antonio Ospite https://ao2.it https://twitter.com/ao2it A: Because it messes up the order in which people normally read text. See http://en.wikipedia.org/wiki/Posting_style Q: Why is top-posting such a bad thing?