Jeff King <peff@xxxxxxxx> writes: > On Wed, Aug 22, 2018 at 12:49:34PM -0400, Derrick Stolee wrote: > >> > Yes, that was what I meant. We actually did switch to that hand-rolled >> > loop, but later we went back to memcmp in 0b006014c8 (hashcmp: use >> > memcmp instead of open-coded loop, 2017-08-09). >> >> Looking at that commit, I'm surprised the old logic was just a for >> loop, instead of a word-based approach, such as the following: >> [...] >> +struct object_id_20 { >> + uint64_t data0; >> + uint64_t data1; >> + uint32_t data2; >> +}; >> + >> static inline int hashcmp(const unsigned char *sha1, const unsigned char >> *sha2) >> { >> - return memcmp(sha1, sha2, the_hash_algo->rawsz); >> + if (the_hash_algo->rawsz == 20) { >> + struct object_id_20 *obj1 = (struct object_id_20 *)sha1; >> + struct object_id_20 *obj2 = (struct object_id_20 *)sha2; > > I wonder if you're potentially running afoul of alignment requirements > here. Yup, and I think that all was discussed in that old thread ;-)