Elia Pinto <gitter.spiros@xxxxxxxxx> writes: > diff --git a/t/t2025-worktree-add.sh b/t/t2025-worktree-add.sh > index be6e09314..658647d83 100755 > --- a/t/t2025-worktree-add.sh > +++ b/t/t2025-worktree-add.sh > @@ -252,6 +252,11 @@ test_expect_success 'add -B' ' > test_cmp_rev master^ poodle > ' > > +test_expect_success 'add --quiet' ' > + git worktree add --quiet ../foo master >expected 2>&1 && > + test_must_be_empty expected > +' That's misnomer. Unless existing tests in this file are already bogus, I'd like to see it called 'actual', which is the name we use to store the actual output (to be compared with another file we create to hold the expected output, typically called 'expect', like "test_cmp expect actual"). I noticed the breakage after merging this to 'pu'; it seems to die with "fatal: ../foo already exists" which comes from die(). Oh, more seriously, since when is it OK to muck with stuff _outside_ the $TRASH_DIRECTORY, e.g. "../foo", which would contaminate t/ directory by creating a direct subdirectly under it? Ahh, and I suspect that it is exactly why I am seeing a failure you did not see---from a previously failed test cycle, "t/foo" is left behind because "make distclean" would not clean it (of course). Do not ever touch anywhere outside $TRASH_DIRECTORY. Is this something we could enforce in our test harness, I wonder... > test_expect_success 'local clone from linked checkout' ' > git clone --local here here-clone && > ( cd here-clone && git fsck )