On Mon, Jul 16, 2018 at 12:37 PM Junio C Hamano <gitster@xxxxxxxxx> wrote: > > Stefan Beller <sbeller@xxxxxxxxxx> writes: > > > The information that is printed for update_submodules in > > 'submodule--helper update-clone' and consumed by 'git submodule update' > > is stored as a string per submodule. This made sense at the time of > > 48308681b07 (git submodule update: have a dedicated helper for cloning, > > 2016-02-29), but as we want to migrate the rest of the submodule update > > into C, we're better off having access to the raw information in a helper > > struct. > > The reasoning above makes sense, but I have a few niggles on the > naming. > > * Anything you'd place to keep track of the state is "information", > so a whole "_information" suffix to the structure name does not > add much value. We've seen our fair share of (meaningless) > "_data" suffix used in many places but I think the overly long > "_information" that is equally meaningless trumps them. I think > we also have "_info", but if we are not going to have a beter > name, let's not be original and stick to "_data" like other > existing codepath. An alternative with more meaningful name is > of course better, though, but it is not all that much worth to > spend too many braincycles on it. agreed. > * Is the fact that these parameters necessary to help populating > the submodule repository are sent on a line to external process > the most important aspect of the submodule_lines[] array? As In terms of what the submodule--helper does, it is. It is not the most important aspect in the big picture, or once we finish the migration to not have shell interpret its output. > this step is a preparation to migrate out of that line/text > oriented IPC, I think line-ness is the least important and > interesting thing to name the variable with. ok. > If I were writing this patch, perhaps I'd do > > struct update_clone_data *update_clone; > int update_clone_nr, update_clone_alloc; > > following my gut, but since you've been thinking about submodule > longer than I have, perhaps you can come up with a better name. That makes sense. We do not need to mention 'submodule' as that ought to be obvious from the file name already and 'update_clone' is just enough to describe what we are doing. Although there is already struct submodule_update_clone, which would be the better candidate for 'update_clone' and this new struct would be used as a helper in that struct, so update_clone_data I'll think of adding a patch to rename that already existing struct (submodule_update_clone -> update_clone) and renaming this to update_clone_data. > > > @@ -1463,8 +1469,9 @@ struct submodule_update_clone { > > const char *recursive_prefix; > > const char *prefix; > > > > - /* Machine-readable status lines to be consumed by git-submodule.sh */ > > - struct string_list projectlines; > > + /* to be consumed by git-submodule.sh */ > > + struct submodule_update_clone_information *submodule_lines; > > + int submodule_lines_nr; int submodule_lines_alloc; > > > > /* If we want to stop as fast as possible and return an error */ > > unsigned quickstop : 1; > > @@ -1478,7 +1485,7 @@ struct submodule_update_clone { > > #define SUBMODULE_UPDATE_CLONE_INIT {0, MODULE_LIST_INIT, 0, \ > > SUBMODULE_UPDATE_STRATEGY_INIT, 0, 0, -1, STRING_LIST_INIT_DUP, 0, \ > > NULL, NULL, NULL, \ > > - STRING_LIST_INIT_DUP, 0, NULL, 0, 0} > > + NULL, 0, 0, 0, NULL, 0, 0, 0} > > The structure definition and this macro definition are nearby, so it > is not crucial, but its probably not a bad idea to switch to C99 > initializers for a thing like this to make it more readable, once > the code around this area stabilizes back again sufficiently (IOW, > let's not distract ourselves in the middle of adding a new feature > like this one). Are we still in the phase of "test balloon" or do we now accept C99 initializers all over the code base? But I agree to defer the conversion for now. Thanks, Stefan