Re: [PATCH 1/2] gitview: Fix the blame interface.

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



"Aneesh Kumar K.V" <aneesh.kumar@xxxxxxxxx> writes:

> @@ -401,7 +402,11 @@ class AnnotateWindow(object):
>  	def data_ready(self, source, condition):
>  		while (1):
>  			try :
> -				buffer = source.read(8192)
> +				# A simple readline doesn't work
> +				# a readline bug ??
> +				buffer=""
> +				buffer = source.read(100)
> +

Are you sure about the first assignment?

> @@ -419,7 +432,8 @@ class AnnotateWindow(object):
>  					m = annotate_line.match(buff)
>  					if not m:
>  						continue
> -					filename = m.group(2)
> +					else:
> +						filename = m.group(2)
>  				else:
>  					self.commit_sha1 = m.group(1)
>  					self.source_line = int(m.group(2))

The script is in contrib/ so I probably shouldn't be nitpicking,
but for this particular hunk, I think (1) this is a no-op
change, and (2) the original is easier to read.

-
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html

[Index of Archives]     [Linux Kernel Development]     [Gcc Help]     [IETF Annouce]     [DCCP]     [Netdev]     [Networking]     [Security]     [V4L]     [Bugtraq]     [Yosemite]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Linux SCSI]     [Fedora Users]

  Powered by Linux