On Wed, May 9, 2018 at 4:13 AM, Taylor Blau <me@xxxxxxxxxxxx> wrote: > diff --git a/builtin/grep.c b/builtin/grep.c > index 5f32d2ce84..f9f516dfc4 100644 > --- a/builtin/grep.c > +++ b/builtin/grep.c > @@ -829,6 +829,7 @@ int cmd_grep(int argc, const char **argv, const char *prefix) > GREP_PATTERN_TYPE_PCRE), > OPT_GROUP(""), > OPT_BOOL('n', "line-number", &opt.linenum, N_("show line numbers")), > + OPT_BOOL(0, "column", &opt.columnnum, N_("show column number of first match")), Two things to consider: - do we ever want columnar output in git-grep? Something like "git grep --column -l" could make sense (if you don't have very large worktree). --column is currently used for column output in git-branch, git-tag and git-status, which makes me think maybe we should reserve "--column" for that purpose and use another name here, even if we don't ever want column output in git-grep, for consistency. - If this is to help git-jump only and rarely manually specified on command line, you could add the flag PARSE_OPT_NOCOMPLETE to hide it from "git grep --<tab>" completion. You would need to use OPT_BOOL_F() instead of OPT_BOOL() in order to add extra flags. -- Duy