On Fri, May 4, 2018 at 2:52 AM, Johannes Schindelin <Johannes.Schindelin@xxxxxx> wrote: > On Thu, 3 May 2018, Eric Sunshine wrote: >> On Thu, May 3, 2018 at 11:30 AM, Johannes Schindelin >> <johannes.schindelin@xxxxxx> wrote: >> > +static const char * const builtin_branch_diff_usage[] = { >> > + N_("git rebase--helper [<options>] ( A..B C..D | A...B | base A B )"), >> >> The formatting of "<options>" vs. "base" confused me into thinking >> that the latter was a literal keyword, but I see from reading patch >> 3/18 that it is not a literal at all, thus probably ought to be >> specified as "<base>". > > Good point. Or maybe BASE? Indeed, that's probably more consistent with 'A', 'B', etc. than <base>. > Or I should just use the same convention as in the man page. Or not, as > the usage should be conciser. > > This is what I have currently: > > static const char * const builtin_branch_diff_usage[] = { > N_("git branch-diff [<options>] <old-base>..<old-tip> <new-base>..<new-tip>"), > N_("git branch-diff [<options>] <old-tip>...<new-tip>"), > N_("git branch-diff [<options>] <base> <old-tip> <new-tip>"), > NULL > }; I can live with this. It's more verbose but more self-explanatory, thus likely a good choice.