Stefan Beller <sbeller@xxxxxxxxxx> writes: > Choose a different color for dates and imitate a 'temperature cool down' > depending upon age. > > Originally I had planned to have the temperature cooldown dependent on > the age of the project or file for example, as that might scale better, > but that can be added on top of this commit, e.g. instead of giving a > date, you could imagine giving a percentage that would be the linearly > interpolated between now and the beginning of the file. > ... > @@ -323,6 +324,7 @@ static const char *format_time(timestamp_t time, const char *tz_str, > #define OUTPUT_SHOW_EMAIL 0400 > #define OUTPUT_LINE_PORCELAIN 01000 > #define OUTPUT_COLOR_LINE 02000 > +#define OUTPUT_HEATED_LINES 04000 How about calling it OUTPUT_SHOW_AGE_WITH_COLOR or something like that instead? Anything with "AGE" in it, if that is what you are trying to indicate, would be more appropriate than "HEATED", which does not convey much meaning to readers unless you explain what determines the temperature in your mind.