Johannes Schindelin <Johannes.Schindelin@xxxxxx> writes: >> But I wonder if this is even easier to follow. It makes it even >> more clear that patchsame commits that are not empty are discarded >> unconditionally. >> >> while ((commit = get_revision(&revs))) { >> int is_empty = is_original_commit_empty(commit); >> if (!is_empty && (commit->object.flags & PATCHSAME)) >> continue; >> strbuf_reset(&buf); >> if (!keep_empty && is_empty) >> strbuf_addf(&buf, "%c ", comment_line_char); >> strbuf_addf(&buf, "%s %s ", insn, >> oid_to_hex(&commit->object.oid)); >> pretty_print_commit(&pp, commit, &buf); >> strbuf_addch(&buf, '\n'); >> fputs(buf.buf, out); >> } >> >> Or did I screw up the rewrite? > > This looks correct. And the postimage is easier to follow than the one of > my suggested change. OK, let's squash this in and rebuild both pw/rebase-keep-empty-fixes and also pw/rebase-signoff that builds on this topic, so that they can be advanced to 'next'.