On Tue, Feb 27, 2018 at 5:04 PM, Jeff King <peff@xxxxxxxx> wrote: > On Tue, Feb 27, 2018 at 01:58:00PM -0800, Junio C Hamano wrote: >> So are we looking for a natural name to call an array of trings? I >> personally do not mind argv_array too much, but perhaps we can call >> it a string_array and then everybody will be happy? > > That would be fine with me. Though I would love it if we could find a > shorter name for the associated functions. For example, > argv_array_pushf() can make lines quite long, and something like > argv_pushf() is easier to read (in my opinion). And that might work > because "argv" is pretty unique by itself, but "string" is not. > > Some one-word name like "strarray" might work, though I find that is not > quite catchy. I guess "strv" is short if you assume that people know the > "v" suffix means "vector". struct strs {...}; void strs_init(struct strs *); void strs_push(struct strs *, const char *); void strs_pushf(struct strs *, const char *fmt, ...); void strs_pushl(struct strs *, ...); void strs_pushv(struct strs *, const char **); void strs_pop(struct strs *); void strs_clear(struct strs *); const char **strs_detach(struct strs *); ...is short, feels pretty natural, and doesn't require understanding "v" for "vector".